Systems and Means of Informatics
2026, Volume 36, Issue 3, pp 47-68
CONGESTION CONTROL ALGORITHM USING EXPONENTIAL VECTOR AUTOREGRESSION
- Fengrui Guo
- R. L. Smeliansky
Abstract
The paper proposes a combined TCP (Transmission Control Protocol) congestion control algorithm that integrates a traditional reactive congestion window control mechanism with a congestion window (Cwnd) prediction procedure based on exponential vector autoregression (EVAR). The method is intended to reduce the period during which the available bandwidth remains underutilized after a congestion event. Once congestion or its signs are detected, EVAR is used to predict the Cwnd value for the next observation interval, and this forecast is applied as a new Cwnd value if it satisfies an additional safety constraint. The safety threshold is defined through the round-trip time (RTT) and limits the use of the forecast when rapid Cwnd recovery may increase queues and cause additional congestion events. The proposed algorithm is evaluated on an ns-3 test stand and compared with NewReno, CUBIC, and BBRV1 . The results show that, compared with the baseline congestion control algorithms, the proposed algorithm makes it possible to obtain at least 0.5 Mbit/s of additional available bandwidth.
[+] References (23)
- Allman, M., V. Paxson, and E. Blanton. 2009. RFC 5681: TCP congestion control. Internet Engineering Task Force. RFC Editor. doi: 10.17487/RFC5681.
- Jacobson, V. 1988. Congestion avoidance and control. ACM SIGCOMM Comp. Com. 18(4):314-329. doi: 10.1145/52324.52356.
- Low, S. H., F. Paganini, and J. C. Doyle. 2002. Internet congestion control. IEEE Contr. Syst. Mag. 22(1):28-43. doi: 10.1109/37.980245.
- Zheng, J., C. Wu, T. Lan, C. Tian, and G. Chen. 2023. Revisiting weighted AIMD- based congestion control: A comprehensive perspective. IEEE/ACM 31st Symposium (International) on Quality of Service Proceedings. IEEE. Art. 10188753. 10 p. doi: 10.1109/IWQoS57198.2023.10188753.
- Wang, R., G. Pau, K. Yamada, M.Y. Sanadidi, and M. Gerla. 2004. TCP startup performance inlarge bandwidth networks. INFOCOM Proceedings. IEEE. 2:796-805. doi: 10.1109/1NFCOM.2004.1356968.
- Guo, Fengrui, V.Yu. Korolev, and R. L. Smelyansky. 2025. On forecasting overlay channel quality. Moscow University Computational Mathematics Cybernetics 49(4):324-332.
- Floyd, S. 2000. RFC 2914: Congestion control principles. Internet Engineering Task Force. RFC Editor. doi: 10.17487/RFC2914.
- Jose, L., L. Yan, M. Alizadeh, G. Varghese, N. McKeown, and S. Katti. 2015. High speed networks need proactive congestion control. 14th Workshop on Hot Topics in Networks Proceedings. New York, NY: ACM. Art. 14. 7 p. doi: 10.1145/ 2834050.2834096.
- Gangane, S., and A. Kakade. 2015. A survey on TCP/IP protocol stack. Int. J. Computer Applications 120(19):39-42.
- Henderson, T., S. Floyd, A. Gurtov, and Y. Nishida. 2012. RFC 6582: TheNewReno modification to TCP's fast recovery algorithm. Internet Engineering Task Force. RFC Editor. doi: 10.17487/RFC6582.
- Ha, S., I. Rhee, and L. Xu. 2008. CUBIC: A new TCP-friendly high-speed TCP variant. ACM SIGOPS Operating Systems Review 42(5):64-74. doi: 10.1145/ 1400097.1400105.
- Hock, M., R. Bless, and M. Zitterbart. 2017. Experimental evaluation of BBR congestion control. 25th Conference (International) on Network Protocols Proceedings. IEEE. Art. 8117540. 10 p. doi: 10.1109/ICNP.2017.8117540.
- Cardwell, N., Y. Cheng, C. S. Gunn, S. Hassas Yeganeh, and V. Jacobson. 2016. BBR: Congestion-based congestion control. ACM Queue 14(5):20-53. doi: 10.1145/3012426.3022184.
- Borisov, A., A. Bosov, G. Miller, and I. Sokolov. 2021. Partial diffusion Markov model of heterogeneous TCP link: Optimization with incomplete information. Mathematics 9(14): 1632. doi: 10.3390/math9141632.
- Dong, M., T. Meng, D. Zarchy, E. Arslan, Y. Gilad, B. Godfrey, and M. Schapira. 2018. PCC Vivace: Online-learning congestion control. 15th Symposium on Networked Systems Design and Implementation Proceedings. Berkeley, CA: USENIX Association. 343-356.
- Agalarov, Ya. M., and M. G. Konovalov. 2019. Dokazatel'stvo unimodal'nosti tselevoy funktsii v zadache porogovogo upravleniya nagruzkoy na server [Proof of unimodality of the objective function in the problem of threshold control of server load]. Informatika i ee Primeneniya - Inform. Appl. 13(2):2-6. doi: 10.14357/19922264190201.
- Rhee, I., L. Xu, S. Ha, A. Zimmermann, L. Eggert, and R. Scheffenegger. 2018. RFC 8312: CUBIC for fast and long-distance networks. Internet Engineering Task Force. RFC Editor. doi: 10.17487/RFC8312.
- Khademi, N., M. Welzl, G. Armitage, and G. Fairhurst. 2018. RFC 8511: TCP alternative backoff with ECN (ABE). Internet Engineering Task Force. RFC Editor.
doi: 10.17487/RFC8511.
- Kilian, L. 2006. New introduction to multiple time series analysis, by Helmut Lutkepohl, Springer, 2005. Economet. Theor. 22(5):961-967. doi: 10.1017/ S0266466606000442.
- Hyndman, R. J., and Y. Fan. 1996. Sample quantiles in statistical packages. Am. Stat. 50(4):361-365. doi: 10.1080/00031305.1996.10473566.
- Hyndman, R.J., and A.B. Koehler. 2006. Another look at measures of forecast accuracy. Int. J. Forecasting 22(4):679-688. doi: 10.1016/j.ijforecast.2006.03.001.
- Fesl, J., T. Capkova, M. Konopa, L. Beranek, J. Fiala, M. Houda, P. Chladek, J. Klicnarova, R. Remes, M. Sulista, K. Vocetkova, and M. Feslova. 2024. Data center TCP dataset. Data Brief 54:110522. doi: 10.1016/j.dib.2024.110522.
- Guo, F. 2026. ns-3-test-stand: TCP test stand for EVAR-based congestion control. Source code repository. GitLab ASVK MSU. Available at: https://gitlab.asvk.cs.msu. ru/guofengrui/ns-3-test-stand/-/tree/main/NS-3%20Stand%20V8/V8.3?ref_type= heads.
[+] About this article
Title
CONGESTION CONTROL ALGORITHM USING EXPONENTIAL VECTOR AUTOREGRESSION
Journal
Systems and Means of Informatics
Volume 36, Issue 3, pp 47-68
Cover Date
2026-11-15
DOI
10.14357/08696527260303
Print ISSN
0869-6527
Publisher
Institute of Informatics Problems, Russian Academy of Sciences
Additional Links
Key words
TCP congestion control; exponential vector autoregression; congestion window prediction; available bandwidth; ns-3 simulation
Authors
Fengrui Guo  and R. L. Smeliansky
Author Affiliations
 Lomonosov Moscow State University, Faculty of Computational Mathematics and Cybernetics, 1 Leninskiye Gory, Moscow 119991, Russian Federation
|